存档

文章标签 ‘Metasploit’

Windows下安装Metasploit

2012年2月5日 3 条评论

很多人在Windows下安装Metasploit会出现如图所示错误,搜索后找到解决办法,记录之..

1、MSF安装过程中需要安装ruby和postgresql,出现”There has been an error.  psql.exe -U postgres -p  ..”,在独立安装postgresql的时候也经常会碰到,主要是因为postgresql的默认字符类型与中文不匹配,将电脑的“区域和语言”改为“英文”,然后再安装就可以,等安装完后再改回“中文”。

2、出现此错误后,会在 服务 中出现frameworkpostgresql,错误多次会出现frameworkpostgresql-1,-2,-3,

\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\frameworkPostgreSQL

删除以上注册表项即可。

 

分类: 技术文档 标签:
普人特福的博客cnzz&51la for wordpress,cnzz for wordpress,51la for wordpress