首页 > 安全工具 > Hydra安装Libssh模块

Hydra安装Libssh模块

2013年1月15日 发表评论 阅读评论

Hydra是一个支持多种网络服务的非常快速的网络登陆破解工具。这个工具是一个验证性质的工具,它被设计的主要目的是为了研究人员和安全从业人员对网络服务进行弱密码探测!

最新发布版本:hydra-7.4.2.tar.gz

当我们使用hydra来探测远程ssh服务口令是否强壮时,如果没有安装libssh模块,程序会给出如下一个错误:

[ERROR] Compiled without LIBSSH v0.4.x support, module is not available!

如何装libssh呢?方法如下:

方法一、支持apt-get的话

apt-get purge hydra
apt-get install cmake libssl-dev

方法二、编译安装

2.1 libssh
wget http://www.libssh.org/files/0.4/libssh-0.4.8.tar.gz
tar zxf libssh-0.4.8.tar.gz
cd libssh-0.4.8
mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Debug -DWITH_SSH1=ON ..
make
make install

2.2 hydra
wget http://www.thc.org/releases/hydra-7.4.2.tar.gz
tar zxvf hydra-7.4.2.tar.gz
cd hydra
./configure
make && make install

分类: 安全工具 标签:
  1. nononono.楼上的要make clean 一下然后再编译,这样模块好像就加入进去了,自然也就不报这个错了。!!!欢迎回访 xiaosan.cnblogs.com

  2. ﹊高仿鞋﹊
    Burberry(巴宝莉)
    Armani(阿玛尼)
    PRADA(普拉达)
    阐幽(化妆品牌)
    LANVIN(浪凡)
    VX:LOveMeJck

普人特福的博客cnzz&51la for wordpress,cnzz for wordpress,51la for wordpress